Missing EOD Stock Prices for US Exchagnes

Incident Report for Intrinio

Resolved

We've received processed all US prices from March 10th.
Posted Mar 11, 2025 - 11:59 EDT

Investigating

EOD stock prices have been delayed from our source. We are working with our provider to get this data deliver ASAP.
Posted Mar 10, 2025 - 22:07 EDT
This incident affected: Web APIs (APIv2, APIv1).